Datenquellen

Nutzen Sie Scopevisio als Datenquelle in Verbindung mit Excel und erstellen Sie Reports, Pivot-Tabellen und Diagramme. Anders als viele andere Buchhaltungsprogramme bietet Ihnen Scopevisio damit die Möglichkeit, neben den integrierten, vordefinierten Berichten viele weitere, selbstdefinierte Reports einzurichten. Sie können ihre gewohnten Excel-Auswertungen und Pivot-Tabellen, die Sie als Controlling-Instrumente verwenden, weiter benutzen und sind jederzeit auskunftsfähig.

Per Knopfdruck können Sie die Daten direkt in Excel aktualisieren. Sobald die Verknüpfung zwischen Scopevisio und Ihrem Controlling-Tool einmal eingerichtet ist, wird Ihr Bericht automatisch in Echtzeit mit Daten aus Scopevisio befüllt.

Berechtigungen einstellen

Um mit Datenquellen arbeiten zu können, sind zwei Berechtigungen notwendig: Das Recht Datenquellen sowie die spezielle Berechtigung, die die Scopevisio Funktion freigibt, aus der die Daten exportiert werden sollen,  z. B. Journal oder Angebote usw. Diese speziellen Berechtigungen sind den Benutzerprofilen zugeordnet. Sie finden sie unter Global > Systemadministration > Benutzerverwaltung > Profile und Rechte der Benutzer verwalten. Hier können Sie Rechte vergeben, vordefinierte Profile an Ihre Mitarbeiter zuweisen oder benutzerdefinierte Profile erstellen.

Allgemeine Berechtigung für Datenquellen

Um das Datenquellen-Recht an Mitarbeiter zu vergeben, empfiehlt es sich, ein Profil zu erstellen, das ausschließlich dieses eine Recht enthält.

Hinweis: Um Datenquellen für andere Benutzer freizuschalten, benötigen Sie Administratorrechte für Scopevisio.

  1. Hierfür wählen Sie Global > Systemadministration > Benutzerverwaltung > Profile und Rechte der Benutzer verwalten und klicken auf Hinzufügen.
  2. Vergeben Sie eine Bezeichnung für das neue Profil, zum Beispiel wie oben gezeigt: Datenquellen.
  3. Schalten Sie nun das Recht zum Anzeigen und Bearbeiten für Datenquellen ein. Das Recht kann unter Auswahl der Anwendung Finanzen eingeschaltet werden.
  4. Bevor die Benutzer auf die Datenquellen zugreifen können, muss dieses neue Profil noch an sie vergeben werden.

Öffnen Sie Global > Systemadministration > Benutzerverwaltung > Benutzer verwalten. Wählen Sie den Benutzer mit einem Doppelklick aus, an den Sie die Berechtigung vergeben möchten.

Im Geschäftsobjekt Benutzerprofile können Sie nun das Profil angeben. Geben Sie zunächst in der Spalte Anwendung Finanzen an, um in der Spalte Profil das neu erstellte Datenquellen-Profil auswählen zu können.

 

Spezielle Berechtigungen für Datenquellen-Typen

Das Datenquellen-Recht alleine bedeutet lediglich, dass die Möglichkeit des Exports von Informationen direkt in Excel für den Benutzer freigeschaltet ist. Im Folgenden sind die Funktionen aufgeführt, aus denen Daten exportiert werden können. Möchte ein Benutzer entsprechende Informationen exportieren, benötigt er auch mindestens die Leserechte für die entsprechende Funktion.

Sollte es einem Mitbenutzer an den nötigen Rechten fehlen, vergeben Sie diese wie oben dargestellt über das Anlegen eines Profils und die Vergabe des Profils an die entsprechenden Mitglieder oder schalten Sie die Funktion in einem bereits vorhandenen Profil frei.

 Journal

  • Zeiterfassung
  • Aufgaben
  • Kontakte
  • Ausgangsrechnungen
  • Eingangsrechnungen
  • Angebot
  • Auftrag
  • Lieferschein
  • Gutschrift
  • Produktverwendung (Ausgangsrechnung)
  • Produktverwendung (Angbebot)
  • Produktverwendung (Auftrag)
  • Produktverwendung (Lieferschein)
  • Produktverwendung (Gutschrift)
  • Produktverwendung (Verkaufschance)
  • Konvertierung
  • Teamwork Dokumente
  • Position (Ausgangsrechnung)
  • Position (Angbebot)
  • Position (Auftrag)
  • Position (Lieferschein)
  • Position (Gutschrift)
  • Position (Verkaufschance)
  • Produkte
  • Verkaufschance
  • Projekte
  • Allgemeine Kontakteigenschaften
  • Änderungsprotokoll
  • Sachkonten (SuSa)
  • Debitoren (SuSa)
  • Kreditoren (SuSa)
  • Rechnungskreis
  • Rechnungskreis-Bezeichnung

Eine weitere Hilfestellung bietet dazu das Formular für den Datenquellenexport. Wenn Sie unter OpenScope > Datenquellen eine Datenquelle einrichten  und die einzelnen exportierbaren Typen aufrufen, können Sie die für den Export benötigten Rechte erkennen und, falls nötig, aktivieren.

Erweiterte Authentifizierung für den Zugriff auf Datenquelleninformationen

Wählen Sie OpenScope > Datenquellen.

Hier erreichen Sie erweiterte Möglichkeiten zum Schutz des Datenquellen-Zugriffs. Neben der einfachen Möglichkeit der Ja/Nein Authentifizierung kann der Zugriff auf bestimmte Benutzer und/oder IP-Adressen beschränkt werden. Über die Schaltfläche Konfigurieren gelangen Sie in die Authentifizierungs-Verwaltung. Hier können mehrere Benutzer (User/Passwort Kombination oder existierender Scopevisio-Nutzer) und IP-Bereiche bzw. IP-Adressen eingestellt werden. Der Zugriff auf die Datenquelle wird gewährt, wenn der Aufrufer mindestens einen Benutzer korrekt eingibt und aus einem der angegebenen IP-Bereiche kommt. Bereits existierende Benutzername/Passwort Kombinationen werden übernommen.

Anlegen der Datenquelle

Öffnen Sie das Formular OpenScope > Datenquellen und klicken Sie auf Hinzufügen, um eine Datenquelle anzulegen. Nachfolgend werden die möglichen Einstellungen erklärt. Die Nummerierung bezieht sich auf die Nummern in der Abbildung oben.

  1. Dieses Lese-Recht wird für den gewählten Datenquellentyp benötigt.
  2. Wählen Sie das Ausgabeformat und den Zeitraum für die Daten.
  3. Falls sich der Benutzer authentifizieren muss, wählen Sie Ja.
  4. Geben Sie den Benutzer und das Kennwort für die Authentifizierung ein.
  5. Aktivieren Sie die Datenquelle.
  6. Geben Sie an, welche Spalten (Datenfelder) exportiert werden sollen. Standardmäßig sind dieselben Spalten ausgewählt, die auch für die Bildschirmanzeige eingeblendet wurden.
Anlegen der Datenquelle

Export einer Datenquelle

Unter dem Link 'Beispiel Spreadsheet Download' können Sie in Scopevisio eine Pivot-Tabelle namens Gewinn- und Verlustrechnung zu Testzwecken herunterladen, die mit den Daten aus der Scopevisio-Datenquelle befüllt wird.

Klicken Sie auf OpenScope > Datenquellen.

  1. Erstellen Sie eine neue Datenquelle, indem Sie auf Neu klicken.
  2. Legen Sie unter dem Geschäftsobjekt Datenquelle zunächst Einstellungen zum Datenquellenabruf fest. So können Sie zunächst den Zeitraum bestimmen, für den die vorhandenen Informationen abgerufen werden sollen.

Tipp: Wählen Sie in der Datumseinstellung einen längeren Zeitraum, etwa 2010-2020, wenn Sie Daten aus der Vergangenheit berücksichtigen und die Datenquelle auch in Zukunft noch längere Zeit nutzen möchten.

  1. Vergeben Sie ein beliebiges Passwort und einen Benutzernamen. Diese Authentifizierung wird dann bei jedem erneuten Abruf der Daten  abgefragt.
  2. Nutzen Sie den Link Spalten konfigurieren, um die zu importierenden Informationen zu bestimmen.
  3. Unter dem Geschäftsobjekt Journal können Sie den Bericht konfigurieren, den Sie erstellen möchten.
  1. Aktivieren Sie die Datenquelle (siehe Screenshot) und speichern Sie Ihre Eingaben.
  2. Nach dem Speichern können Sie durch Klicken auf das Symbol neben dem Datenquellen-Link diesen in die Zwischenablage kopieren:

 

Vorgehen in Excel

Öffnen Sie ein neues Excel Dokument, um den Datenquellen-Link zu importieren und somit die Daten in ein neues Arbeitsblatt einzufügen.

Klicken Sie auf den Reiter Daten und wählen Sie im Bereich Externe Daten abrufen die Option Aus dem Web.

 

In das Feld Adresse fügen Sie den kopierten Datenquellen-Link aus Ihrer Zwischenablage ein. Dies bestätigen Sie mit einem Klick auf OK und markieren die zu importierende Tabelle über den gelben Pfeil, sobald diese geladen ist. Anschließend klicken Sie auf Importieren.

Das Arbeitsblatt wird nun mit den erforderlichen Daten gefüllt. Eine Pivot-Tabelle können Sie über den Reiter Einfügen in dem Bereich Diagramme erstellen.

Um die Daten zu aktualisieren, wählen Sie den Button Alle aktualisieren im Reiter Daten.

Mehrere Datenquellen zusammenführen

Wenn Sie eine Excel-Arbeitsmappe öffnen, können Sie mehrere Tabellen darin anlegen. Mit jeder Tabelle lässt sich auch eine Scopevisio-Datenquelle verknüpfen. Sie können z. B. in Tabelle 1 Daten über Abrechnungsbelege und in Tabelle 2 Projektdaten laden, um diese dann in Tabelle 3 zu einer Auswertung zu kompilieren, die die Informationen aus den verschiedenen Datenquellen zueinander in Beziehung setzt.

Damit gibt Ihnen Scopevisio ein sehr umfangreiches Auswertungstool für Ihr Unternehmenscontrolling an die Hand.